Pixelated or Missing Images
Incident Report for Leadpages
Resolved
We can confirm that the issue with pixelated or missing images has resolved. All the images within impacted accounts have been restored and are functioning normally. Thank you for your patience!
Posted Oct 30, 2018 - 23:09 CDT
Update
Google's team has identified the issue and are in the process of implementing a fix. We have seen an improvement with images loading on published Leadpages. We will continue to provide updates as they become available.
Posted Oct 30, 2018 - 22:42 CDT
Identified
We have been notified that Google Cloud is experiencing image loading issues. A link to the status page can be found here: https://www.google.com/appsstatus#hl=en&v=issue&sid=1&iid=80db5d6458ec8a82796cff01cd648324

We are working with Google's development team to resolve this incident. More information will be provided as it becomes available.
Posted Oct 30, 2018 - 22:11 CDT
Investigating
We are currently investigating reports of pixelated or missing images on Leadpages. We are actively investigating the issue and will provide more information as soon as it becomes available.
Posted Oct 30, 2018 - 21:38 CDT
This incident affected: Landing pages and Published landing pages.