Degraded Lead Notifications Email Performance
Incident Report for Leadpages
Resolved
Our development team has implemented a change to allow Lead Notifications to resume normal function. Previously queued and newly submitted Lead Notifications emails are being successfully delivered to their intended recipients once again.

Thank you so much for your patience!
Posted Jul 03, 2018 - 15:54 CDT
Investigating
We are currently investigating delays with our third party email delivery provider. These delays impact Lead Notifications emails being delivered to customers. All opt-ins are being collected and are available by exporting the CSV file on Standard and Drag & Drop pages and Leadboxes.

Leads can be exported using the steps found here: https://support.leadpages.net/hc/en-us/articles/224748167

We will provide updates as they become available.
Posted Jul 03, 2018 - 15:00 CDT
This incident affected: Integrations.